БЛОГ


Включение PHP 7 заметно ускоряет работу сайта, но при переходе на седьмую версию некоторые шаблоны работают с ошибками.  Разработчики клубных шаблонов, как правило, выкладывают решения, как перевести шаблоны и расширения на новую платформу.
В этой заметке о решениях от студии Smartaddons.

Google Map

Ошибка:
Plugin_googleMaps имеет устаревшую конструкцию в /plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php в строке 385

Решение:
Открыть : /plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php
Найти: function Plugin_googleMaps
Заменить на: function __construct

Опубликовано в БЛОГ